Mantis Bugtracker          
testlink.org

View Revisions: Issue #7150 All Revisions ] Back to Issue ]
Summary 0007150: Copying builds without release date fails (POSTGRES)
Revision 2015-06-07 08:11 by fman
Description Version 1.9.13 has an issue with copying builds that do not have a release date set. It occurs when you try to copy a testplan including the builds and assignments.

Output in event log:
     ERROR ON exec_query() - database.class.php
0 - - /* Class:testplan - Method: copy_builds */ INSERT INTO builds (name,notes,release_date,testplan_id) VALUES ('>18234','','', 50713)
THE MESSAGE : /* Class:testplan - Method: copy_builds */ INSERT INTO builds (name,notes,release_date,testplan_id) VALUES ('>18234','','', 50713) Query failed: errorcode[0] errormsg:

This is new in version 1.9.13, the previous version didn't take release dates into account.
Revision 2015-06-05 13:34 by dstraube
Description Version 1.9.13 has an issue with copying builds that do not have a release date set. It occurs when you try to copy a testplan including the builds and assignments.

Output in event log:
     ERROR ON exec_query() - database.class.php
0 - - /* Class:testplan - Method: copy_builds */ INSERT INTO builds (name,notes,release_date,testplan_id) VALUES ('>18234','','', 50713)
THE MESSAGE : /* Class:testplan - Method: copy_builds */ INSERT INTO builds (name,notes,release_date,testplan_id) VALUES ('>18234','','', 50713) Query failed: errorcode[0] errormsg:

This is new in version 1.9.13, the previous version didn't take release dates into account.



Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker